Cómo emplear los condicionales en Excel

Cálculo del IVA completo

Para aprender un poco sobre las funciones condicionales en Excel, vamos a seguir con el ejemplo de la publicación sobre Sumas en Excel.

Teníamos un listado con importes, donde aprendimos a crear una fórmula para calcular el IVA y sumar los totales, que nos quedó así:

Excel con cálculo de IVAEl problema que nos planteamos es cómo hacer que no aparezcan valores cuando no existe importe en la fila correspondiente.

Pues para esta tarea vamos a emplear funciones condicionales, en concreto, la función SI (dependiendo del idioma de Excel varía el nombre de la función, en inglés es if).

La sintaxis de esta función de forma entendible, es la siguiente:

SI ( <comparación que queremos hacer> ; <Qué hacer si el resultado es cierto> ; <Qué hacer si el resultado es falso>)

Aplicado a este ejemplo en la primera casilla deberíamos escribir =SI( A2 <> “” ; “”; A2*1,21), es decir:

  • ¿Qué queremos comprobar? Si en la casilla de importe hay algo. En el “idioma” de Excel se expresa A2 <> “”, es decir, si el valor de la casilla A2 es distinto ( <> ) de nada (dobles comillas)
  • ¿Qué hacemos si se cumple la condición? Poner el cálculo del IVA que hicimos anteriormente.
  • ¿Qué queremos hacer en caso de que sí se cumpla la condición?  Si no hay importe no queremos que ponga nada. Así que aquí tenemos que poner las comillas dobles

Este es el método directo, que será vuestro preferido cuando hayáis ejercitado un poco, pero por si se os olvida la sintaxis o si queréis hacerlo de una forma diferente, aquí os detallo otro método.

Primero borramos las fórmulas que pusimos en las casillas del IVA, marcamos la primera casilla de IVA y pulsamos sobre el símbolo fx como se aprecia aquí:

Insertar FunciónNos abrirá una ventana donde nos aparecerá un listado con todas las funciones de Excel. Ahí elegimos la función SI y tras aceptar mostrará una ventana donde nos explicará todos los parámetros de la función. Ahí rellenamos cada campo con el valor correspondiente, tal como hicimos antes y quedará así:

Como ya hemos hecho la fórmula para la primera casilla, sólo nos queda copiarla al resto y comprobar que efectivamente funciona:

  Cálculo de IVA completoAhora volvemos a utilizar la función SI, pero esta vez aplicado al cálculo de total con IVA de la columna siguiente y todo quedará así:

Podéis descargar el archivo de Excel de este ejemplo, pulsando aquí: ejemploExcel1

Por último os dejo con una pregunta ¿qué ocurriría si en lugar de la fórmula utilizada, empleamos esta otra: =SI(A2=””; “”; A2*1,21) ?

Sumas en Excel

Excel Totales

Imaginemos que nos han encargado hacer un listado de facturas, donde tenemos que incluir una columna con el Importe total de cada factura antes de impuestos, otra columna calculando el IVA que le corresponde y una última columna con el Total. Al final de la página necesitamos sumar los totales de cada columna. Sería algo así:

Excel 01Lo primero que debemos hacer es aplicar el formato adecuado a las celdas donde pondremos los valores, en este caso el formato moneda. Para ello, primero seleccionamos todas las celdas que utilizaremos y, tras esto, pulsamos el botón derecho del ratón sobre la selección. Aparecerá un menú desplegable donde elegiremos Formato de Celdas. Se abrirá una ventana con las opciones disponibles y ahí elegiremos el formato Moneda y pulsamos Aceptar. Quedará así:

Ahora introduzcamos unos cuantos datos de ejemplo en la columna de Importes y calculemos el total en la parte de abajo.

Tecleamos unos valores al azar y si introducimos más de 2 decimales, veremos como los redondea a 2, gracias al formato que le aplicamos en el paso anterior. Para que calcule el total, marcamos la celda del Importe Total en la parte de abajo y tecleamos lo siguiente =suma( ahora marcamos con el ratón toda la columna donde están los importes y veremos como se completa la fórmula automáticamente. También podemos escribirlo normalmente y quedará: =suma(A2:A13)Excel TotalesPara ahorrar tiempo ahora sólo tenemos que copiar la celda del importe total y pegarla en los otros totales y Excel se encargará de ajustar los nombres de las columnas de forma automática.

Ahora vamos a calcular el IVA. Marcamos la primera celda de IVA y escribimos =A2 * 1,21 y pulsamos enter. Veremos como aparecerá el valor del IVA correspondiente. Ahora copiamos esa celda y la pegamos en el resto de la columna y tendremos listo nuestro cálculo del IVA.

Podemos comprobar que los cálculos se han realizado correctamente, pero en las filas donde no hay ningún importe aparece 0,00€ en la columna de IVA. Para solucionar esto, podemos borrar las fórmulas donde no hay importes o podemos recurrir a una solución más profesional que os mostraré en la próxima publicación: Cómo emplear los condicionales. Hasta la próxima.